Son İletiler

Sayfa: [1] 2 3 ... 10
1
Arkadaşlar herkese iyi günler, formülle ilgili çözemediğim bir soru vardı yardımcı olacaklara şimdiden teşekkürler.

üç satırım var, bu satırda dolu olanları saydırmak istiyorum (bazen 1, bazen 2, bazen 3 olabiliyor) eğersay ile saydırıyor, şarta uyuyorsa mesela dolu hücre 1 ise 2 yazsın, dolu hücre 2 ise 1 yazsın, dolu hüre 3 ise "yok" yazsın, dolu hücre yoksa "3" yazsın, bunu aşağıdaki formülle yapmaya çalıştım, tek eğerde sonuç veriyor, ancak daha sonrakilerde "DEĞER" hatası veriyor, yardımcı olacak arkadaşlara şimdiden teşekkürler.

=EĞER(EĞERSAY(B1:B3;"<>")=1;2);EĞER(EĞERSAY(B1:B3;"<>")=2;1);EĞER(EĞERSAY(B1:B3;"<>")=3;"YOK");EĞER(EĞERSAY(B1:B3;"<>")=0;3)

SONUÇ #DEĞER!
2
Microsoft Excel, Vba, Makro, Formül vb. Soruları / Ynt: çektopla yardım
« Son İleti Gönderen: Orion1 12 Ekim 2018, 23:56:31 »
Örnek dosya eklerseniz daha çabuk yanıt alabilirsiniz. 8)
3
Textboxa veri girmek örneği.
Kod: [Seç]
Private Sub TextBox1_AfterUpdate()
TextBox1.Value = VBA.FormatNumber(TextBox1.Value, 2)
End Sub

textboxtan sayfaya veri atma örneği.:cool:
Kod: [Seç]
Private Sub CommandButton1_Click()
Range("G1").Value = CDbl(TextBox1.Value)
Range("G1").NumberFormat = "#,##0.00"
End Sub
4
Microsoft Excel, Vba, Makro, Formül vb. Soruları / Ynt: Kapat Makrosu Hatası
« Son İleti Gönderen: Orion1 12 Ekim 2018, 23:37:54 »
VBE de Bu çalışma kitabı içinde Workbook_BeforeClose olayında kod var büyük ihtimalle.
O olayın içindeki kodları silerseniz sorun biter.:cool:
5
Microsoft Excel, Vba, Makro, Formül vb. Soruları / Kapat Makrosu Hatası
« Son İleti Gönderen: katip16487 08 Ekim 2018, 15:45:26 »
Sub Auto_Close()
Unload anasayfa
    Sheets("verigiris").Select
    ActiveWorkbook.Save
    Dim WScript As Object
        Set WScript = CreateObject("WScript.Shell")
        X = WScript.popup("Belgeniz kaydedilmiştir, kolay gelsin. Hakim Ahmet Revan KULA", 1, "KAPATMA UYARISI")
    Application.Quit
End Sub

şeklinde kullanmakta olduğum KAPAT makrom bulunmakta. Ancak makro çalıştığı zaman POPUP olarak belirlediğim yazı ekrana 2 defa gelmektedir.

Amacım, ÇARPI işareti kullanılmaksızın programdan EXCEL dosyasını kapatmak suretiyle kendiliğinden çıkış yapmasıdır.
POPUP zaten 1 saniye kadar çalışmaktadır.

Hatayı giderebilirseniz sevinirim.

Saygılarımla...
6
Private Sub UserForm_Initialize()
Set s1 = Sheets("alfabe")
TextBox1.Text = s1.Range("B2").Value
TextBox2.Text = s1.Range("B3").Value
End Sub

Çok sayıda TextBox içeren bi UserForm'um bulunmakta ve bu formda yer alan TextBox'lara ondalıklı sayısal değer veya yüzde içeren veriler girilmektedir.

Veriler TextBox'a girilip çıkıldığında ilgili Excel hücresine otomatik olarak verilerin aktarılması sağlanmaktadır.

A) RAKAM OLARAK AKTARMA HATASI
1) TextBox'a veri girişi yapıp çıktığımda yazılan sayısal ifadeyi ondalık ayracı olmadan göstermektedir. (Örnek 1234,5)
Ben TextBox görümünün binlik ayracı (.) ve ondalık ayracı (,) olacak şekilde olmasını ve ayrıca ondalık sayı hanesinin 2 olmasını sağlamak istiyorum, ancak bu durumu yazdığım kod ile bir türlü sağlayamamaktayım. (Örnek 1.234,50) veya (1.234,50 TL)

2) Bu şekilde yaptığım veri girişlerini Excel sayfasına "Metin Olarak Saklanan Sayı" şeklinde aktarmaktadır ve bu durum da Excel'in hesap yapmasına engel olmakta ve matematiksel işlemlerde hata oluşturmaktadır.

*** Bu hatanın giderilmesi için, yani TextBox görüntüsünün (1234,5) yerine (1.234,50) olmasını; Excel ilgili hücreye matematiksel hesapta hata olmaması açısından rakam olarak aktarmasını sağlamak için yukarıda yazılı koda ne şekilde eklemem yapmam gerektiği hususunda bilginizi talep ediyorum.

B) YÜZDE OLARAK AKTARMA HATASI
1) TextBox'a veri girişi yapıp çıktığımda yazılan yüzdelik ifadeyi yazıldığı rakam şeklinde göstermektedir.  (Örnek 12)
Ben TextBox görümünün ondalık ayracı (,) olacak şekilde olmasını ve ayrıca ondalık sayı hanesinin 2 veya zaman zaman 3 olmasını sağlamam gerekmekte, ancak bu durumu yazdığım kod ile bir türlü sağlayamamaktayım. (Örnek 12,50 % veya 6,831 %)

2) Bu şekilde yaptığım veri girişlerini (örnek 12) Excel sayfasına (1200,00 %) şeklinde aktarmaktadır. Bu durum ise verinin 100 kat fazlası bir sonuca ulaşmasına ve matematiksel olarak hata oluşmasına neden olmaktadır.

*** Bu nedenle TextBox'a 12 şeklinde yazıldığında görüntünün (12,00 %); 1,5 yazıldığında görüntünün (1,50 %) şeklinde olmasını ve ayrıca Excel ilgili hücrenin (1200,00 %) şeklinde değil, (12,00 %) şeklinde aktarmasını ve matematiksel hesabın bu şekilde yapılmasını istiyorum.

Biraz uzun oldu ama kusuruma bakmayın.

Şimdiden teşekkürler. Kolaylıklar dilerim. Yardımınızı bekliyorum.
7
Sayın Emre bey
Siz zaten neredeyse cevabını yazmışsınız biraz daha deneme yapsanız olacakmış.

Kod: [Seç]
=EĞER(A1/5=TAMSAYI(A1/5);A1/5;YUKARIYUVARLA(A1/5;1)+1)
8
Herkese merhabalar
Aşağıda metin olarak yazabildiğim ancak formule edemediğim formulü yazabilir misiniz yada yön gösterebilir misiniz bana?
Herkese şimdiden teşekkürler

=eğer((A1/5=tamsayı ise ; (A1/5) ; değil ise (yukarıyuvarla(A1/5)+1))

yada

=eğer((A1 5e tambölünebiliyor ise ; (A1/5) ; değil ise (yukarıyuvarla(A1/5)+1))
9
Merhabalar,

Flanş sayfasındaki ürün kodları ile sayfa1 sayfasındaki kodları karşılaştırıyor (sayfa1 deki flanş düğmesine basınca); eksik kod olduğunda makro hata uyarısı veriyor; makro duruyor. Bunun yerine eksik olan kodu (flanş sayfasındaki L81 deki kodu) Madde Listesi1 sayfasındaki A sütununun en altına ekleyip, makronun da çalışmasını yarıda kesmek yerine kaldığı yerden devam edeceği yeni bir düzenleme yapılabilir mi? (aynı düzenlemenin FITTING düğmesi için de olması gerekmektedir)



Teşekkür Ederim.

İyi çalışmalar dilerim.
10
Merhaba,

Elinize sağlık. Çalışıyor.

Teşekkürler.
Sayfa: [1] 2 3 ... 10