Gönderen Konu: Türe göre toplama  (Okunma sayısı 192 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı sahika51

  • Excelce Onbaşı
  • **
  • İleti: 3
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: ferudun soy
  • Doğum Yılınız: 1974
  • İl / İlçe: niğde
  • İşletim Sisteminiz: win 7
  • Office Versiyonunuz: 2010
Türe göre toplama
« : 22 Ocak 2018, 22:14:31 »
Dosyaya açıklama yazdım. Epey uğraştım amaraştırdım ama buna uygun bir formül veya makro bulamadım. yardım!!!!

Çevrimdışı Bülent Öztürk

  • Excelce.Net Yönetici
  • *
  • İleti: 1316
  • Puan +19/-0
  • Cinsiyet: Bay
  • Türkçe Konuşup Excelce Yazıyoruz...
    • Bülent Öztürk
  • Ad Soyad: Bülent Öztürk
  • İl / İlçe: İstanbul / Çorlu
  • İşletim Sisteminiz: Win.10
  • Mesleğiniz: Bilgi Teknolojileri
  • Office Versiyonunuz: Office2013/2016
Ynt: Türe göre toplama
« Yanıtla #1 : 23 Ocak 2018, 12:58:31 »
Şöyle deneyin isterseniz;

Kod: [Seç]
=EĞER(B4="M";TOPLA(C4:AG4);EĞER(B5="M";TOPLA(C5:AG5);EĞER(B6="M";TOPLA(C6:AG6);EĞER(B7="M";TOPLA(C7:AG7);EĞER(B8="M";TOPLA(C8:AG8))))))
=EĞER(EYOKSA("Google Arama");"Belki_Cevap_Burada";"")

Çevrimdışı sahika51

  • Excelce Onbaşı
  • **
  • İleti: 3
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: ferudun soy
  • Doğum Yılınız: 1974
  • İl / İlçe: niğde
  • İşletim Sisteminiz: win 7
  • Office Versiyonunuz: 2010
Ynt: Türe göre toplama
« Yanıtla #2 : 23 Ocak 2018, 18:32:48 »
teşekürler. Bu aklımda vardı zaten ama şunuda önerdiler sağolsun
=TOPLA.ÇARPIM(($B4:$B8=SOLDAN(AH$3;1))*($C4:$AG8))
ama bu makrolu olmazmı düşündüm.

Çevrimdışı Bülent Öztürk

  • Excelce.Net Yönetici
  • *
  • İleti: 1316
  • Puan +19/-0
  • Cinsiyet: Bay
  • Türkçe Konuşup Excelce Yazıyoruz...
    • Bülent Öztürk
  • Ad Soyad: Bülent Öztürk
  • İl / İlçe: İstanbul / Çorlu
  • İşletim Sisteminiz: Win.10
  • Mesleğiniz: Bilgi Teknolojileri
  • Office Versiyonunuz: Office2013/2016
Ynt: Türe göre toplama
« Yanıtla #3 : 24 Ocak 2018, 08:07:45 »
Bu çalışmanızda makroya gerek yok, formüller işinizi görür.
Topla.Çarpım daha uygun bir çözüm olacaktır.
=EĞER(EYOKSA("Google Arama");"Belki_Cevap_Burada";"")