Gönderen Konu: EXCELDE NUMARALANDIRMA  (Okunma sayısı 666 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı okankg

  • Excelce Onbaşı
  • **
  • İleti: 4
  • Puan +0/-0
  • Excel'den Daha Fazlası!..
  • Ad Soyad: OKAN UMUT
  • Doğum Yılınız: 1990
  • İl / İlçe: KOCAELİ ÇAYIROVA
EXCELDE NUMARALANDIRMA
« : 23 Mayıs 2017, 15:12:44 »
merhaba;
excelde A sütununa veri girdikçe B sütununda otomatik olarak sıralı numara vermesini istiyorum.
verileri girdiğim sıraya göre numaralndırmak istiyorum. bunu yapan formülü kuramadım

örnek: A1 hücresine veri girdiğimde B1 hücresine 1 yazmasını
          A9 hücresine veri girdiğimde B9 hücresine 2 yazmasını
          A3 hücresine veri girdiğimde B3 hücresine 3 yazmasını

Çevrimdışı hasan14

  • Excelce Onbaşı
  • **
  • İleti: 34
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Hasan çıtır
  • Doğum Yılınız: 1961
  • İl / İlçe: Zonguldak/Ereğli4
Ynt: EXCELDE NUMARALANDIRMA
« Yanıtla #1 : 23 Mayıs 2017, 17:14:58 »
B1 Hücresine kopyala aşağı çek
Kod: [Seç]
=EĞER(A1="";"";BAĞ_DEĞ_DOLU_SAY($A$1:A1))

Çevrimdışı okankg

  • Excelce Onbaşı
  • **
  • İleti: 4
  • Puan +0/-0
  • Excel'den Daha Fazlası!..
  • Ad Soyad: OKAN UMUT
  • Doğum Yılınız: 1990
  • İl / İlçe: KOCAELİ ÇAYIROVA
Ynt: EXCELDE NUMARALANDIRMA
« Yanıtla #2 : 24 Mayıs 2017, 10:13:34 »
Çok teşekkür ederim hasan14. Formül çalışıyor ama ufak bir eksik var
A1     hücresine veri girdiğimde B1     hücresine 1 yazıyor
A2     hücresine veri girdiğimde B2     hücresine 2 yazıyor
A10   hücresine veri girdiğimde B10   hücresine 3 yazıyor

Ama
A7   hücresine veri girdiğimde B10   hücresine 4 yazmıyor
B10 da 3 yazıyorken; A7   hücresine veri girdiğimde B10 daki sayıyı 4 yapıyor, B7 deki sayıya 4 yazıyor.

Benim istediğim farklı satırlara yazsamda sıra numarasının değpişmemesi
Yazdığım sıraya göre numaralandırma yapması

EXCELDE ekledim.tşkler

Çevrimdışı hasan14

  • Excelce Onbaşı
  • **
  • İleti: 34
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Hasan çıtır
  • Doğum Yılınız: 1961
  • İl / İlçe: Zonguldak/Ereğli4
Ynt: EXCELDE NUMARALANDIRMA
« Yanıtla #3 : 24 Mayıs 2017, 11:01:02 »
Formülle istediğinizin nasıl yapılacağını bilmiyorum.Makro ile olabilir.Sayfa koduna kopyala
Kod: [Seç]
Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Intersect(Target, Range("a2:a100")) Is Nothing Then Exit Sub
If Target = "" Then
Target.Offset(0, 1) = ""
Else
Target.Offset(0, 1) = WorksheetFunction.Max(Range("B2:B100")) + 1
End If
End Sub
Dosyanız;

Çevrimdışı okankg

  • Excelce Onbaşı
  • **
  • İleti: 4
  • Puan +0/-0
  • Excel'den Daha Fazlası!..
  • Ad Soyad: OKAN UMUT
  • Doğum Yılınız: 1990
  • İl / İlçe: KOCAELİ ÇAYIROVA
Ynt: EXCELDE NUMARALANDIRMA
« Yanıtla #4 : 24 Mayıs 2017, 14:09:52 »
elinize sağlık.çok teşekkür ederim  :)

Çevrimdışı hasan14

  • Excelce Onbaşı
  • **
  • İleti: 34
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Hasan çıtır
  • Doğum Yılınız: 1961
  • İl / İlçe: Zonguldak/Ereğli4
Ynt: EXCELDE NUMARALANDIRMA
« Yanıtla #5 : 24 Mayıs 2017, 14:21:32 »
Rica ederim.Kolay gelsin :bye