Gönderen Konu: Saat aralığına göre işlem  (Okunma sayısı 46 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı pasha22

  • Excelce Onbaşı
  • **
  • İleti: 3
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Yasin Baş
  • Doğum Yılınız: 1978
  • İl / İlçe: istanbul
Saat aralığına göre işlem
« : 02 Aralık 2019, 17:04:47 »
Merhabalar;
Ekteki dosyada "E" sütunundaki Kullanıcı Çıkışından - Kullanıcı Girişine ("G" sütununda) kadar geçen zaman 10 dk ve üzeri ise "0" olarak, 10 dk ya kadar olanlar ise "1" olarak yandaki tabloya nasıl yansıtırız?
Saygılarımla.

Not: "C" sütunudaki ekipman numarasına göre cihazların açılış kapanışı

https://dosyayukle.biz/SZh

Çevrimdışı Bülent Öztürk

  • Excelce.Net Yönetici
  • *
  • İleti: 1329
  • Puan +19/-0
  • Cinsiyet: Bay
  • Türkçe Konuşup Excelce Yazıyoruz...
    • Bülent Öztürk
  • Ad Soyad: Bülent Öztürk
  • İl / İlçe: İstanbul / Çorlu
  • İşletim Sisteminiz: Win.10
  • Mesleğiniz: Bilgi Teknolojileri
  • Office Versiyonunuz: Office2013/2016
Ynt: Saat aralığına göre işlem
« Yanıtla #1 : 03 Aralık 2019, 08:48:46 »
Merhaba,

Formülü aşağıdaki gibi değiştirin:
Kod: [Seç]
=EĞER(DAKİKA(EĞER(C3=C2;G3-G2;0))<10;1;0)
Hücreleri de sayı olarak biçimlendirin.
(Ücretli program talepleriniz için iletişime geçebilirsiniz, excelvbprogram@gmail.com)

Çevrimdışı pasha22

  • Excelce Onbaşı
  • **
  • İleti: 3
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Yasin Baş
  • Doğum Yılınız: 1978
  • İl / İlçe: istanbul
Ynt: Saat aralığına göre işlem
« Yanıtla #2 : 03 Aralık 2019, 16:03:50 »
Merhaba Bülent Bey;
Dediğiniz formülü uyguladım ama istediğim veriyi vermiyor, mesela ilk ekipman açılış saati 11:22:27 de, yani yan tarafta 07:00-07:05 arası 0 olması lazım, 11:22 de açıldığı için de 11:20-11:25 aralığı 1 olmalı.
Bilgilendirmeyi eksik yaptım sanırım, benim amacım bir ekipmanın açık kaldığı süreleri yandaki 5 dk lık tabloya aktarmak. Açık olduğu zaman aralığı=1, kapalı olduğu zaman aralığı ise=0 olmalı.
Bunu da şu şekilde ayırdım kendimce, "E" sütununda Kullanıcı giriş yapınca çıkışa kadar cihaz açık yani=1 ancak yine "E" sütununda kullanıcı çıkışı sonrası kullanıcı girişine kadar geçen süre 10 dk ve üzeri ise o zaman aralığı kapalı=0 olmalı ama bunu formüle yansıtamadım.
İnşallah anlatabilmişimdir.
Saygılarımla.

Çevrimdışı pasha22

  • Excelce Onbaşı
  • **
  • İleti: 3
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Yasin Baş
  • Doğum Yılınız: 1978
  • İl / İlçe: istanbul
Ynt: Saat aralığına göre işlem
« Yanıtla #3 : 06 Aralık 2019, 01:02:52 »
güncel.