Gönderen Konu: [Çözüldü] Topla Çarpım Hakkında  (Okunma sayısı 6293 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı drejan62

  • Excelce Çavuş
  • ***
  • İleti: 111
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: ercan
[Çözüldü] Topla Çarpım Hakkında
« : 12 Nisan 2010, 09:57:02 »
Merhabalar,
Ekteki dosyada rapor sayfasına
Kod: [Seç]
TOPLA.ÇARPIM((A2=yatma!$A$2:$A$20000)*(G2=yatma!$G$2:$G$20000)*(H2=yatma!$H$2:$H$20000))kodunu girdiğimde sonuç 1 çıkıyor yani formül çalışıyor fakat benim ihtiyacımı tam karşılamıyor.
Ben formülü;
Kod: [Seç]
TOPLA.ÇARPIM((A2=yatma!$A$2:$A$20000)*(G2=yatma!$G$2:$G$20000)*(H2=yatma!$H$2:$H$20000)*(yatma!$D$2:$D$20000))şeklinde yaparak yatma safasında D sütunundaki değeri almak istiyorum. Üste 2. kodu girdiğimde ise
Kod: [Seç]
#DEĞER!
  çıkıyor
Hata nerde veya aradığım yatma sayfasındaki D sütunundaki değeri nasıl elde edebilirim.

Teşekkürler

[Forum yazılım güncelleme esnasında sorun oluştuğundan eklendi silinmiştir.]

Çevrimdışı Orion1

  • Excelce Teğmen
  • ****
  • İleti: 351
  • Puan +10/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Evren Gizlen
Ynt: Topla Çarpım Hakkında
« Yanıtla #1 : 12 Nisan 2010, 12:23:26 »
O formülle D süğtunundaki sayısal değerleri toplamya çalışıyor.Fakat d sütununda sayısal değer olmadığı metin olduğu için hata veriyor.

Çevrimdışı drejan62

  • Excelce Çavuş
  • ***
  • İleti: 111
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: ercan
Ynt: Topla Çarpım Hakkında
« Yanıtla #2 : 12 Nisan 2010, 13:24:08 »
O formülle D süğtunundaki sayısal değerleri toplamya çalışıyor.Fakat d sütununda sayısal değer olmadığı metin olduğu için hata veriyor.
Sağolun üstad,
peki bunun bir çözümü olabilirmi?

Çevrimdışı Orion1

  • Excelce Teğmen
  • ****
  • İleti: 351
  • Puan +10/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Evren Gizlen
Ynt: Topla Çarpım Hakkında
« Yanıtla #3 : 12 Nisan 2010, 13:26:38 »
Sağolun üstad,
peki bunun bir çözümü olabilirmi?
Bu formülle şartlara uyan d sütunundaki sayıların toplamı alınıyor.Siz ne yapmak istiyorsunuz?

Çevrimdışı drejan62

  • Excelce Çavuş
  • ***
  • İleti: 111
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: ercan
Ynt: Topla Çarpım Hakkında
« Yanıtla #4 : 12 Nisan 2010, 13:49:20 »
Bu formülle şartlara uyan d sütunundaki sayıların toplamı alınıyor.Siz ne yapmak istiyorsunuz?

Üstad ben,
rapor sayfasında V sütununa   yatma sayfasındaki d sütununda yazan ismi getirmek istiyorum fakat iki şartında eşit olması gerekiyor.
bu iki şart şunlar;
rapor sayfasındaki a sütunundaki değer ile yatma sayfasındaki a sütunundaki değerin ve yine rapor sayfasındaki g sütunundaki değer ile yatma sayfasındaki değerin işit olması halinde yatma sayfasındaki d sütunundaki değerin gelmesini istiyorum.
Örnekte aynı tarihte (01.12.2009), ayni numara (123456) lı işlemin yatma sayfasandıki d sütunundaki değerin (MEHMET) rapor sayfasında v1
hücresine yazdırmak istiyorum.

Umarım anaşılır olmuştur.
Tekrar teşekkürler

Çevrimdışı Orion1

  • Excelce Teğmen
  • ****
  • İleti: 351
  • Puan +10/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Evren Gizlen
Ynt: Topla Çarpım Hakkında
« Yanıtla #5 : 12 Nisan 2010, 14:56:17 »
Üstad ben,
rapor sayfasında V sütununa   yatma sayfasındaki d sütununda yazan ismi getirmek istiyorum fakat iki şartında eşit olması gerekiyor.
bu iki şart şunlar;
rapor sayfasındaki a sütunundaki değer ile yatma sayfasındaki a sütunundaki değerin ve yine rapor sayfasındaki g sütunundaki değer ile yatma sayfasındaki değerin işit olması halinde yatma sayfasındaki d sütunundaki değerin gelmesini istiyorum.
Örnekte aynı tarihte (01.12.2009), ayni numara (123456) lı işlemin yatma sayfasandıki d sütunundaki değerin (MEHMET) rapor sayfasında v1
hücresine yazdırmak istiyorum.

Umarım anaşılır olmuştur.
Tekrar teşekkürler
Kullanıcı tanımlı fonksiyon yaptım.
Standart bir modüle koydum.Dosyanız ektedir. 8)
Kullanılışı:
=uclu_sart_bul(A2;G2;H2)

Kod: [Seç]
Function uclu_sart_bul(deg1 As Range, deg2 As Range, deg3 As Range) As String
Dim k  As Range, adr As String, sat As Long
sat = Cells(65536, "A").End(xlUp).Row
Set k = Sheets("yatma").Range("H2:H" & sat).Find(deg3, , xlValues, xlWhole)
If Not k Is Nothing Then
    adr = k.Address
    Do
        If deg2 = k.Offset(0, -1).Value And deg1 = k.Offset(0, -7).Value Then
            uclu_sart_bul = k.Offset(0, -4).Value
            Exit Function
        End If
        Set k = Sheets("yatma").Range("H2:H" & sat).FindNext(k)
    Loop While Not k Is Nothing And k.Address <> adr
End If
End Function

[Forum yazılım güncelleme esnasında sorun oluştuğundan eklendi silinmiştir.]

Çevrimdışı drejan62

  • Excelce Çavuş
  • ***
  • İleti: 111
  • Puan +0/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: ercan
Ynt: Topla Çarpım Hakkında
« Yanıtla #6 : 12 Nisan 2010, 15:04:30 »
Üstat çok teşekkürler.
sağolun.
saygılar

Çevrimdışı Orion1

  • Excelce Teğmen
  • ****
  • İleti: 351
  • Puan +10/-0
  • Cinsiyet: Bay
  • Excel'den Daha Fazlası!..
  • Ad Soyad: Evren Gizlen
Ynt: Topla Çarpım Hakkında
« Yanıtla #7 : 12 Nisan 2010, 15:24:41 »
Rica ederim.
İyi çalışmalar. 8)

Çevrimdışı Bülent Öztürk

  • Excelce.Net Yönetici
  • *
  • İleti: 1319
  • Puan +19/-0
  • Cinsiyet: Bay
  • Türkçe Konuşup Excelce Yazıyoruz...
    • Bülent Öztürk
  • Ad Soyad: Bülent Öztürk
  • İl / İlçe: İstanbul / Çorlu
  • İşletim Sisteminiz: Win.10
  • Mesleğiniz: Bilgi Teknolojileri
  • Office Versiyonunuz: Office2013/2016
Ynt: [Çözüldü] Topla Çarpım Hakkında
« Yanıtla #8 : 13 Nisan 2010, 12:42:14 »
Aşağıdaki TOPLA.ÇARPIM formülü D sütununda sayı olması durumunda çalışıyor ancak metin olması durumunda çalışmıyor.  ???

Kod: [Seç]
=TOPLA.ÇARPIM((yatma!A2:A1000=A2)*(yatma!G2:G1000=G2);(yatma!D2:D1000))
=EĞER(EYOKSA("Google Arama");"Belki_Cevap_Burada";"")